Bug Tracker

Opened 8 years ago

Closed 8 years ago

#11148 closed bug (invalid)

Focus event doesn't fire, but focusin fires twice

Reported by: dmethvin Owned by: dmethvin
Priority: high Milestone:
Component: event Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Reported by @DonTAbrams

http://jsfiddle.net/donabrams/MLnRg/

Change History (5)

comment:1 Changed 8 years ago by dmethvin

Component: unfiledevent
Milestone: None1.7.2
Priority: undecidedhigh

comment:2 Changed 8 years ago by dmethvin

Owner: set to dmethvin
Status: newassigned

comment:3 Changed 8 years ago by donabrams@…

The fiddle affected by the regression is this: http://jsfiddle.net/donabrams/MLnRg/1/

comment:4 Changed 8 years ago by dmethvin

Milestone: 1.7.2
Status: assignedpending

Don, can you refresh me on where/why this was not working correctly? I am not seeing a problem. If you could create a simple test case that didn't include the whole plugin that would help.

http://jsfiddle.net/MLnRg/10/

It's possible that focusin firing twice is correct. If a focus event was fired below the element handling the event, it will be bubbled as a focusin and must be attached as such if it's a bound (vs delegated) event.

comment:5 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.