Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#11133 closed bug (duplicate)

jQuery.one() function doesn't remove "mouseenter" event after first call

Reported by: joepjoosten Owned by: dmethvin
Priority: low Milestone: None
Component: event Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

A one time "mouseenter" event created with jQuery.one("mouseenter", function(){}) is fired every time. Conclusion: event doesn't get removed.

Bug probably is in jQuery.event.remove function

Change History (6)

comment:1 Changed 7 years ago by joepjoosten

comment:2 Changed 7 years ago by dmethvin

Component: unfiledevent
Milestone: None1.7.2
Owner: set to dmethvin
Priority: undecidedlow
Status: newassigned

Confirmed.

comment:4 Changed 7 years ago by dmethvin

Milestone: 1.7.2None
Resolution: duplicate
Status: assignedclosed

Thanks @gibson042, I thought it looked familiar but must have done the jquery-git test wrong when I checked it.

comment:5 Changed 7 years ago by dmethvin

Duplicate of #10984.

comment:6 Changed 7 years ago by swain

It is really Serious!

Note: See TracTickets for help on using tickets.