Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#11127 closed bug (invalid)

object doesn't support property or method "addEventListener"

Reported by: inVader Owned by: inVader
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

object doesn't support property or method "addEventListener" jquery-1.7.1.js, line 464 symbol 4 IE 9.0, Windows 7

Could be fixed by changing line 459 to if ( document.addEventListener && window.addEventListener ) {

next error is

object doesn't support property or method "removeEventListener" jquery-1.7.1.js, line 922 symbol 3

Could be fixed by changing line 920 to

if ( document.removeEventListener ) {

Change History (4)

comment:1 Changed 8 years ago by inVader <valery.latushko@…>

this bug exists since jquery-1.4 jquery-1.3.2 doesn't have this bug

comment:2 Changed 8 years ago by Rick Waldron

Owner: set to inVader
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate:  http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 6 years ago by anonymous

This bug cannot be reproduced in JSFiddle, because it only appears to happen in MSIE compatability mode which JSFiddle itself doesn't support.

the error is thrown from JQuery.ready.promise, to reproduce open Internet Explorer, use $(document).ready( fn ), open dev console (F12) and set the Document mode to IE7 Standards. I'm using JQuery edge in my tests:

jQuery.ready.promise = function( obj ) {

if ( !readyList ) {

readyList = jQuery.Deferred(); if ( document.readyState === "complete" ) {

setTimeout( jQuery.ready );

} else {

[ERROR Thrown here] document.addEventListener( "DOMContentLoaded", completed, false ); window.addEventListener( "load", completed, false );

}

} return readyList.promise( obj );

};

Note: See TracTickets for help on using tickets.