Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#11102 closed bug (worksforme)

Syntax error

Reported by: [email protected] Owned by: [email protected]
Priority: low Milestone: None
Component: web Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by sindresorhus)

When i use search function on your website by keyword 'createDelegate' Firebug display: missing } after function body [Break On This Error] }).replace("<style id='flashfire...ashFirebug_init();}catch(e){}},false); Delegate (line 66) syntax error [Break On This Error] ([<])/g,"<script>window.onload = (function(){\ntry{")

Change History (2)

comment:1 Changed 10 years ago by sindresorhus

Description: modified (diff)
Owner: set to [email protected]
Status: newpending

I assume you're using Firefox, since you mention Firebug.

I could not reproduce your problem in either Firefox 8 or 9.

Can you please add your browser version and url to the page showing the problem?

Also make sure it's not your addons causing the problem, by testing it in Firefox safemode.

comment:2 Changed 10 years ago by addyosmani

Component: unfiledweb
Priority: undecidedlow
Resolution: worksforme
Status: pendingclosed

Thanks for submitting a ticket to to the jQuery bug tracker. I haven't been able to reproduce this issue either in the latest versions of FF, but based on your error sample, it appears to occur when Firebug is open (perhaps there's a missing '}') as mentioned) in one of our scripts.

We're currently working on refreshed versions of all our sites and even with Firebug open, they appear to no longer have the same problem. As the newer sites will be getting pushed out in the near future, I'll be closing this ticket as worksforme.

(if another team member has access to fix this quickly and feels its warranted, please feel free to reopen).

Note: See TracTickets for help on using tickets.