Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#11033 closed bug (duplicate)

1.7.1 on not bubbling dynamically created dropdowns in IE7/8 on change

Reported by: constant.newb@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am new to reporting bugs apologies for any mistakes. I have raised this issue on Stackoverflow and put up two examples on jsFiddle (links below) to see if anybody else had spotted this issue or I had been making a silly mistake. I did search the open tickets but couldnt find reference.

The issue is when using 'on' on a surrounding element with several dropdowns in, the bubbling that jQuery replicates in IE8 and below works very well. However when adding new drop downs dynamically inside the surrounding element the bubbling doesnt work for those elements in IE8 and below. It does work in other browsers.

Its almost as if the bubbling that jQuery simulates (according to the documentation) is not added to any new elements within the set, rather than it being a dynamic thing. Ive got the work around of applying direct handlers on the elements when creating them, so I am simply raising the issue as it was unexpected.

StackOverflow Original Issue jsFiddle Edited jsFiddle

Thanks, Lee

Change History (2)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

It's on the list to fix in 1.7.2; workaround is in the original ticket.

comment:2 Changed 8 years ago by dmethvin

Duplicate of #10878.

Note: See TracTickets for help on using tickets.