Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10991 closed bug (invalid)

can't find the XML element including colon(even after //)

Reported by: raincolee@… Owned by: raincolee@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Sorry I have to use google reader API to show this bug because I can't reproduce it with other XML.

$.get("http://www.google.com/reader/atom/feed%2Fhttp%3A%2F%2F37signals.com%2Fsvn", function(data) {
   console.log($(data).find("gr\\:continuation"));
});
=> []

but in fact, this XML looks like:

<feed >
<!-- Content-type: Preventing XSRF in IE. -->
<generator uri="http://www.google.com/reader">Google Reader</generator>
<id>
tag:google.com,2005:reader/feed/http://37signals.com/svn
</id>
<title>Signal vs. Noise</title>
<subtitle type="html">Signal vs. Noise</subtitle>
<gr:continuation>CK_-lYXU4qsC</gr:continuation>
<updated>2011-11-17T03:16:02Z</updated>
...

jQuery can't retrieve the 'gr:continuation' element, but can retrieve all other elements. I thinks it's a bug.

Change History (3)

comment:1 Changed 8 years ago by sindresorhus

Owner: set to raincolee@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 8 years ago by dmethvin

Sounds like #10377 but a test case would clarify.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.