Bug Tracker

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#10971 closed feature (duplicate)

Support for "input" event in textfield

Reported by: benjamin.chevillon.mma@… Owned by:
Priority: low Milestone: None
Component: event Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:


I think a .onInputChange method would be useful to detect the change of a text input. As it can be shown here http://jsfiddle.net/BenChe/T3mkt/, the modern browser supports the "input" event which is fired when a textfield is changed (nevermind the way it is changed : key, click on old values, copy/paste, etc.) and the event is fired as soon as the value is changed. It does not wait to lose the focus. I think it would be great if a .onInputChange method bind to the "input" event on browser that support it, and use a timer on old browser.

Regards, Thanks,

Benjamin Chevillon

Change History (3)

comment:1 Changed 4 years ago by sindresorhus

  • Component changed from unfiled to event
  • Keywords 1.8-discuss added
  • Priority changed from undecided to low
  • Status changed from new to open

This will most likely not make it into core because:

  • Only support in modern browsers
  • Really buggy implementation in IE9
  • We're trying to minimize the bloat of jQuery

This would be better suited as a plugin or a polyfill, but I'll add it as a 1.8 feature request, so it can be voted on.

input event spec.

comment:2 Changed 4 years ago by timmywil

  • Keywords 1.8-discuss removed
  • Resolution set to duplicate
  • Status changed from open to closed

This was already voted down in 1.7.

comment:3 Changed 4 years ago by timmywil

Duplicate of #9121.

Note: See TracTickets for help on using tickets.