Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10953 closed bug (duplicate)

AJAX default contentType should include the charset

Reported by: rodrigo.rosenfeld Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

Tomcat (6, at least) uses ISO-8859-1 as default charset, when not specified. So, jQuery should specify the charset too in the contentType. Since it is encoding the content in UTF-8, the default content-type should be "application/x-www-form-urlencoded; charset=UTF-8".

I had real problems with the current defaults, Chrome and Tomcat 6.

I couldn't reopen ticket #4624, so I'm opening this one.

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Resolution: duplicate
Status: newclosed

I've reopened the other ticket for review. Closing this one as a dupe.

comment:2 Changed 8 years ago by addyosmani

Duplicate of #4624.

Note: See TracTickets for help on using tickets.