Bug Tracker

Opened 13 years ago

Closed 12 years ago

#1091 closed bug (wontfix)

Sortable boxes crashes safari

Reported by: smashlong Owned by: stefan
Priority: undecided Milestone: 1.2
Component: interface Version: 1.1.2
Keywords: safari sortable crash Cc:
Blocked by: Blocking:

Description (last modified by scott.gonzal)

Step to reproduce

  1. Open page with sortables (e.g. http://interface.eyecon.ro/demos/sort.html)
  2. Drag item
  3. Drop item on some place

Actual resutl: Safari browser crashed.

Change History (8)

comment:1 Changed 13 years ago by brauchlik

Am seeing the same on Mac OS X 10.4.9 with Safari 2.0.4. On some pages, when an a sortable item is dropped, Safari crashes (examples of interface demos). On other pages, items simply cannot be dropped.

comment:2 in reply to:  description Changed 13 years ago by smashlong

I google similiar issue with scriptaculos http://dev.rubyonrails.org/ticket/2310

Seems like they've fixed it already.

comment:3 Changed 13 years ago by fifi

Safari 2.0.4 on Mac OS X 10.4.9 also crashes on the autocompletion-demo of interface (http://interface.eyecon.ro/demos/autocompleter.html). Not as fast, but it does latest on the return-click. The bug could be in the hole library, perhaps !?

comment:4 Changed 13 years ago by timmaffett

As of 4/16/07 this seems to be fixed in the jquery latest and the version included on the sortable demo on the http://interface.eyecon.ro site. ( http://interface.eyecon.ro/demos/sort.html no longer crashes safari when used with the new jquery.js (it seems to be a change to the .clean function involving duplicating a array of dom objects (look for 'arg = [];' around line 500).

comment:5 in reply to:  4 Changed 13 years ago by foolingmachi

Replying to timmaffett: This is still broken for me, on both demo pages. PowerPC G4 1.5GHz, 10.4.9, Safari 2.0.4. It reliably crashes no matter which item I drag, but only when it gets dropped, not on the drag.

comment:6 Changed 13 years ago by fifi

i just tested it on the demo-site and it crashed again.

one thing is wondering to me: i installed the sortable-plugin for my site either, using the firefox instead. i also tried out the safari - and it worked! because my script is part of an administration-page, i copied one demopage and placed it here for demonstration. so feel free to test it.

just note: MY page is fine and workin' on me. perhaps you can find any hint either !?

comment:7 Changed 13 years ago by andyzzz

ativan diflucan ativan ativan celexa sonata ativan imitrex flomax ativan levitra levitra guaranteed cheapest online levitra com cialis levitra prescriptionscom viagra cialis levitra levitra clinical data cialis levitra sales viagra buy levitra online viagra cialis levitra levitra viagra buy levitra levitra softabs buy levitra online levitra online discount levitra order levitra levitra danger viagra cyalis levitra compared cialis compare levitra viagra which is better viagra cialis or levitra flonase levitra myonlinemeds biz nexium stimula nexium celebrex levitra nexium propecia renova valtrex viagra nexium side effects new yorker prilosec nexium between difference nexium prilosec nexium pharmacy paxil wiki levitra generic paxil paxil ultram lexapro paxil prozac zoloft paxil side effects prozac zoloft paxil zoloft versus paxil prozac vs paxil paxil vs zoloft paxil versus zoloft buspar celexa prozac paxil anafranil paxil withdrawal symptoms how to switch from paxil to celexa paxil zoloft between difference paxil zoloft paxil vs prozac depression celexa vs paxil prozac paxil paxil prozac vs zoloft or paxil zoloft paxil prozac prozac interactions with viagra cialis levitra ultram and prozac drug interaction prozac ultram prozac nation prozac side effects lexapro paxil prozac zoloft prozac zoloft paxil prozac vs paxil soma buy cialis levitra low online pharmacy price soma viagra drug interaction soma ultram drug soma akane soma buy soma soma mandal buy soma online prozac soma soma carisoprodol online prozac soma boards chongqed carisoprodol generic soma viagra cialis phentermine soma carisoprodol soma soma pharmacy buy cheap drugs lipitor tricor cardizem soma soma prozac soma online zoloft levitra lipitor online pharmacy pharmacy zoloft phentermine levitra low price pharmacy zoloft phentermine viagra ultram zoloft zoloft ultram zoloft ultram interaction zoloft side effects zoloft litigation weight, zoloft vs. lexapro zoloft versus lexapro lexapro zoloft zoloft and lexapro zoloft vs lexapro zoloft lexapro side effects lexapro versus zoloft zoloft lexapro comparison lexapro vs. zoloft changing from zoloft to lexapro weight gain more zoloft or lexapro which is better for anxiety lexapro or zoloft lexapro paxil prozac zoloft zyrtec levitra myonlinemeds biz vaniqa zyrtec myonlinemeds biz ultram ultram zyrtec 2737 aid amerimedrx com ultram zyrtec allegra claritin zyrtec claritin allegra zyrtec zyrtec cetirizine hcl lots of allergies just one zyrteco zyrtec clartin allegra zyrtec and allegra used together zyrtec and allegra combined combining allegra with zyrtec to treat hives zyrtec vs allegra myonlinemeds biz nexium zyrtec allegra zyrtec zyrtec claritin claritin zyrtec allegra vs zyrtec zyrtec and allegra zyrtec zantac error zyrtec side effects carisoprodol valium zyrtec

comment:8 Changed 12 years ago by scott.gonzal

Description: modified (diff)
Resolution: wontfix
Status: newclosed

Interface is no longer supported; consider switching to jQuery UI.

Note: See TracTickets for help on using tickets.