Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10907 closed bug (invalid)

triggering custom events with namespace triggers "property xxx of object yyy is not a function"

Reported by: stryjewski.t@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

when i attached jQ UI autocomplete to input and tried to trigger custom event called "automplete.foo" it throws me an error

"Uncaught TypeError: Property 'autocomplete' of object #<HTMLInputElement> is not a function"

live example: http://jsfiddle.net/stryju/zWGvh/

Change History (4)

comment:1 Changed 8 years ago by dmethvin

Resolution: invalid
Status: newclosed

There is an autocomplete property on that element, which the code is trying to call. Use .triggerHandler() if you don't want to execute a default action.

comment:2 Changed 7 years ago by dmethvin

#12041 is a duplicate of this ticket.

comment:3 Changed 7 years ago by dmethvin

#12073 is a duplicate of this ticket.

comment:4 Changed 7 years ago by gnarf

although this kinda sucks cuz triggerHandler doesn't propagate... just don't name your custom events things that are properties on elements I guess?

Note: See TracTickets for help on using tickets.