Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1089 closed bug (duplicate)

ajaxError throws exception in IE6

Reported by: jonathan Owned by:
Priority: major Milestone: 1.1.3
Component: ajax Version: 1.1.2
Keywords: ajaxError ajaxSetup ajaxForm Cc:
Blocked by: Blocking:

Description

While applying a default timeout for all ajax calls, the ajaxError handler throws an exception in IE6 (FF & Safari do not).

Code snippet:

$(document).ready(function() {

//setup global ajax timeout option
$.ajaxSetup( {timeout: 5000} );

//create jquery object to contain the error messages
eErrorMessages = $("#errors");

//attache the ajaxError listener to the eErrorMessages jquery object
eErrorMessages.ajaxError(function(request, settings){
 $(this).empty();
 $(this).addClass("errorMessages");
 $(this).append('<p class="error">Were sorry, but we could not complete your request at this time. Please try again later.</p>');
 $(this).fadeIn("slow");
});

$("#dynamicForm").ajaxForm({target: '#output'});

});

Error Message (from IE6 debugging window):

Line: 1
Char: 1
Error: The data necessary to complete this operation is not yet available
Code: 0

jQuery version used: 1.1.2

Change History (1)

comment:1 Changed 13 years ago by brandon

Resolution: duplicate
Status: newclosed

Duplicate of #1088

Note: See TracTickets for help on using tickets.