Bug Tracker

Opened 7 years ago

Closed 7 years ago

#10872 closed bug (invalid)

$(<selector>).html(<string>) isnt working right in IE-8

Reported by: hui_buh-@… Owned by: hui_buh-@…
Priority: low Milestone: None
Component: manipulation Version: 1.7.1
Keywords: Cc:
Blocked by: Blocking:

Description

In IE-8 (and 7 and 6 i guess as well) the html() function isnt working well.

I am loading stuff with ajax and put it in a div (#content). But the content isnt shown complete. There is a lot of stuff missing.

I solved the problem by using the javascript method (document.getElementByID('content').innerHtml = insert;) with this its working quite well.

Regards Eike

For detailed informations email me.

Change History (3)

comment:1 Changed 7 years ago by timmywil

Component: unfiledmanipulation
Owner: set to hui_buh-@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by souCE

I cant realy test it, or reproduce the error, because i have no idea WHY he is not working on that specific string.

For detailed informations email me with msn, skype or icq, or give me an irc channel. Then i can give you the string (which is realy long).

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.