Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10816 closed bug (duplicate)

pageX missing from mouse events in jQ1.7

Reported by: rnice@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7
Keywords: Cc: scott_gonzalez
Blocked by: Blocking:

Description

In JQ 1.6.4 on line 3019:

props: "altKey attrChange attrName bubbles button cancelable charCode clientX clientY ctrlKey currentTarget data detail eventPhase fromElement handler keyCode layerX layerY metaKey newValue offsetX offsetY pageX pageY prevValue relatedNode relatedTarget screenX screenY shiftKey srcElement target toElement view wheelDelta which".split(" "),

becomes in JQ 1.7:

props: "attrChange attrName relatedNode srcElement altKey bubbles cancelable ctrlKey currentTarget eventPhase metaKey relatedTarget shiftKey target timeStamp view which".split(" "),

which is a problem in jquery.ui.widget.js lines 390ish, where it's copying properties into the mouse event. pageX and pageY are no longer copied which is causing a great deal of 3rd party utility libraries to no longer be able to drag and drop because for some reason they're using pageXY instead of the UI object.

I see that in 1.7 a new mouseHooks function is there which UI doesn't seem to know about, which is going to be related.

No idea whose problem this is going to be :)

Change History (4)

comment:1 Changed 8 years ago by Rick Waldron

Cc: scott_gonzalez added

I believe UI has made updates for this. I'll CC scott gonzalez to confirm

comment:2 Changed 8 years ago by dmethvin

This is similar if not a dup of #10729, where mikesherov and I were talking about a solution. I wasn't sure of the extent of use of the drag/drop events and whether it made sense to do this.

comment:3 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

I'm going to mark this as a dup, can anyone concerned about this please post in that ticket with more information about the plugins that use it?

comment:4 Changed 8 years ago by dmethvin

Duplicate of #10729.

Note: See TracTickets for help on using tickets.