Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10787 closed bug (duplicate)

Selecting by [nodeName] finds nothing in 1.7

Reported by: drew.wells00@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

The syntax being discussed here is performing a find on a jQuery wrapped document.

var xml = "<doc><dsp></dsp></doc>",
    $xml = $( $.parseXML( xml ) );

$xml.find('[nodeName=dsp]');

Tests in:

1.6.4 (works): http://jsfiddle.net/vZkUH/

1.7.0: http://jsfiddle.net/xABKx/1/

edge: http://jsfiddle.net/fmWHj/1/

I repeated these tests with localName and got the same results. Perhaps there is a simple solution to workaround this.

Change History (2)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

It was a bug that it worked before. The XML does not have a nodeName attribute. See the dup ticket for solutions.

comment:2 Changed 8 years ago by dmethvin

Duplicate of #10377.

Note: See TracTickets for help on using tickets.