Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10769 closed bug (duplicate)

SCRIPT5007 error when loading jQuery after DOM ready

Reported by: logutov@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

In IE 9 in IE 7 mode I got SCRIPT5007 error if I load jQuery with lazy-loading technique (document.createElement("script") and document.body.appendChild).

Error on line jQuery.js 1658:

testElement.innerHTML = ""; testElementParent.removeChild( testElement );

Thats because before this statement there is a function block that set "testElement = container = null;" and this block should be called only on DOM ready. But since I load jQuery after DOM ready it executed immediately and set testElement to null.

Change History (2)

comment:1 Changed 8 years ago by timmywil

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by timmywil

Duplicate of #10737.

Note: See TracTickets for help on using tickets.