Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10756 closed enhancement (worksforme)

file drop event dataTransfer undefined

Reported by: sfornengo@… Owned by:
Priority: low Milestone: None
Component: event Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

$("#dropbox").on("drop",function(e){

e.dataTransfer undefined

} not using jquery: $("#dropbox")[0].addEventListener("drop",function(e){

e.dataTransfer.files works as expected

},false);

http://jsfiddle.net/NU8m7/

Change History (5)

comment:1 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by dmethvin

Duplicate of #10729.

comment:3 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: closedreopened

comment:4 Changed 8 years ago by Rick Waldron

Component: unfiledevent
Priority: undecidedlow
Resolution: worksforme
Status: reopenedclosed

Use an even property fix hook :)

jQuery.event.fixHooks.drop = { props: [ "dataTransfer" ] };

See: http://jsfiddle.net/rwaldron/6AXjU/

comment:5 Changed 8 years ago by Rick Waldron

Note: See TracTickets for help on using tickets.