Bug Tracker

Opened 7 years ago

Closed 7 years ago

#10748 closed bug (invalid)

Firefox 7 doesn't work well with property val() of textareas

Reported by: luca450mhz@… Owned by: luca450mhz@…
Priority: low Milestone: None
Component: attributes Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

I've a textarea with id="performance" and when I make: var perf = $('#performance').val() the value returned is '[object Performance]'. This thing happens only with Firefox 7. I've tried with Explorer, Chrome and other version of Firefox and result it's correct. Is a Firefox's bug or a jquery bug?

Thanks

Change History (3)

comment:1 Changed 7 years ago by anonymous

The problem is that the variable that contains the value must have a different name from the id. Ex. name = $('#name').val() name = '[object Name]';

n = $('#name').val() n contains the correct value of textarea with id name

comment:2 Changed 7 years ago by timmywil

Component: unfiledattributes
Owner: set to luca450mhz@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.