Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10735 closed bug (invalid)

Using "$(document).ready" causes warning about getAttributeNodeNS() being deprecated in Firefox

Reported by: mkogan Owned by:
Priority: low Milestone: None
Component: misc Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

Load the following page in Firefox 8 with the web console open:

<html>
	<head>
		<script src="jquery-1.7.js"></script>
		<script>
			$(document).ready(function() {
				alert(8);
			});
		</script>
	</head>
</html>

and you get the warning:

"Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead."

It seems to be line 1556:

tds[ 0 ].style.display = "";

that's causing it.

Change History (11)

comment:1 Changed 8 years ago by timmywil

Component: unfiledmisc
Priority: undecidedlow

That's strange because we don't use getAttributeNodeNS anywhere. Perhaps it's actually firebug using it. We use getAttributeNode, but not in firefox.

comment:2 Changed 8 years ago by manish.tech2@…

I'm getting same issue... :(

comment:3 Changed 8 years ago by timmywil

Keywords: needsreview added
Status: newopen

comment:4 Changed 8 years ago by mkogan

My apologies, it seems to be caused by Firebug (it doesn't happen when Firebug is disabled).

comment:5 Changed 8 years ago by timmywil

Keywords: needsreview removed
Resolution: invalid
Status: openclosed

Thank you, I figured.

comment:6 Changed 8 years ago by anonymous

After some experimenting I found that the las version of jQuery to not cause this warning was jQuery 1.4.2

To be honest I'm not sure if it is of any help in tracking down the cause or who is generating it but what I did find is that any web page using jQuery 1.4.3 or later with firebug enabled will cause this message to appear. Disabling firebug or removing jQuery from the page will stop this from displaying.

comment:7 in reply to:  6 Changed 7 years ago by anonymous

Replying to anonymous:

After some experimenting I found that the las version of jQuery to not cause this warning was jQuery 1.4.2

To be honest I'm not sure if it is of any help in tracking down the cause or who is generating it but what I did find is that any web page using jQuery 1.4.3 or later with firebug enabled will cause this message to appear. Disabling firebug or removing jQuery from the page will stop this from displaying.

Just tick "Show JavaScript warnings" in the Console tab of Firebug, then you will see the warning for sure.

I'm using jQuery 1.7.1 in Firefox 10.0.2 + Firebug 1.9.1 on Windows 7 SP1 32bits.

comment:8 Changed 7 years ago by Yann Dìnendal

I also get this warning with Firefox's console (Ctrl+Shift+K).

comment:9 Changed 7 years ago by anonymous

I also get a variation of this warning with Firefox 8: "Use of getAttributeNode() is deprecated. Use getAttribute() instead." (getAttributeNode, not getAttributeNodeNS)

Note1: this started to happen after I installed Firebug and other extensions of Firefox.

Note2: then I disabled all the newly installed extensions but it did not remove the warning even after many restart of Firefox; this warning was happening on the first tab of Firefox; then I created a brand new html page with exact same content, and without closing Firefox I opened it on another tab of Firefox and the warning did not display, this time. So I simply killed the incriminated tab. Then I opened another instance of Firefox to open the initial incriminated html page in the first tab of Firefox, and no problem anymore. Apparently a Firefox problem. Strange.

comment:10 Changed 7 years ago by anonymous

Use of getAttributeNodeNS() is deprecated. Use getAttributeNS() instead. in wordpress

comment:11 Changed 7 years ago by dmethvin

Please read the message above; we don't use getAttributeNodeNS. Uninstall Firebug. See the if problem persists.

Note: See TracTickets for help on using tickets.