Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10728 closed bug (duplicate)

$.ajax doesn't persist with deferred methods

Reported by: timothy.soehnlin@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

When calling $.ajax(...).always(), the returned deferred is not the $.ajax() object (As it was in jQuery 1.6), but is now a new promise that is missing all of the $.ajax() members.

This now means that I am unable to chain the $.ajax() deferred methods as a method return.

Change History (2)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by dmethvin

Duplicate of #10723.

Note: See TracTickets for help on using tickets.