Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10695 closed bug (duplicate)

Inconsistent behaviour of show()

Reported by: silesianlordt Owned by:
Priority: high Milestone: None
Component: effects Version:
Keywords: Cc:
Blocked by: Blocking:

Description

Showing element( for ex. span with display:none) while it is in variable is inconsistent. After adding stored element into DOM it is:
-visible in FF
-not visible in IE, Chrome

<!DOCTYPE HTML >
<html>
<head>

<script type="text/javascript" src="jquery-1.7.js"></script>
<script type="text/javascript">
	$(document).ready(function(){
		
		$('#do').click(function(){
			
			var cloo = $('<span>def</span>');
			var place = $('#place');
			
			cloo.show();
			
			place.append(cloo);
			
		});
		
	});
</script>

<style type="text/css">
span {display:none;}
</style>
</head>
<body>

<div id="do">DO</div>
<div id="place"></div>

	
</body>
</html>

Change History (2)

comment:1 Changed 8 years ago by Rick Waldron

Component: unfiledeffects
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by Rick Waldron

Duplicate of #10006.

Note: See TracTickets for help on using tickets.