Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10686 closed bug (duplicate)

Defining jQuery using AMD's define should be done after all of jQuery has been defined.

Reported by: timmywil Owned by:
Priority: low Milestone: 1.7.1
Component: core Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

requirejs does not have a problem with the placement, but curl.js does.

From @unscriptable: "jQuery1.7 AMD bug: jQuery calls define() too early. dependent modules can execute before all of jQ is defined."

If I understand this correctly, moving the call to outer should fix it.

Change History (5)

comment:1 Changed 7 years ago by timmywil

Component: unfiledcore
Milestone: None1.7.1
Owner: set to timmywil
Priority: undecidedlow
Status: newassigned

comment:2 Changed 7 years ago by timmywil

It would be nice to include tests for all of the popular amd loaders.

comment:3 Changed 7 years ago by timmywil

Owner: timmywil deleted
Status: assignedopen

comment:4 Changed 7 years ago by timmywil

Resolution: duplicate
Status: openclosed

John made a report himself.

comment:5 Changed 7 years ago by timmywil

Duplicate of #10687.

Note: See TracTickets for help on using tickets.