Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#10665 closed bug (duplicate)

[nodeName$="something"] does not work anymore

Reported by: jan.mate@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

Because jQuery not supports namespaces and sometimes the user get XML with namespace defined, it is impossible to select element with unknown namespace but known element name. For example:

  • if I know the namespace I can use $('ns
    :element') - the $('element') not works in all browsers
  • in the jQuery 1.6.4 it was possible to use $('nodeName$=:element') to select and element with unknown namespace but in the 1.7 this not works

So the question is how to select elements in 1.7 with unknown namespace?

Change History (2)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by dmethvin

Duplicate of #10377.

Note: See TracTickets for help on using tickets.