Bug Tracker

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#10663 closed bug (duplicate)

Highcharts line chart does not work with jQuery 1.7

Reported by: istvan.m.antal Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.7
Keywords: Cc:
Blocked by: Blocking:


Higcharts is a popular charting library that uses jQuery and generates SVG charts.

With jQuery 1.7, the line chart no longer works, the lines are absent.

Test case: http://jsfiddle.net/mCLRn/

Lines aren't visible in 1.7, they only show once switched to an older version of jQuery.

Change History (3)

comment:1 Changed 4 years ago by istvan.m.antal

Highcharts homepage: http://www.highcharts.com/

The test case is the basic Line chart example taken from: http://www.highcharts.com/demo/

This may have something to do with the SVG path element, or anything that is required to show curved lines.

Also the SVG elements seem to be present, which may hint that the browser did not do a repaint.

Tested browsers: recent versions of both Chrome and Firefox.

comment:2 Changed 4 years ago by dmethvin

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 4 years ago by dmethvin

Duplicate of #10658.

Note: See TracTickets for help on using tickets.