Bug Tracker

Opened 7 years ago

Closed 6 years ago

#10608 closed bug (invalid)

1.7 rc1 crashes phonegap blackberry

Reported by: mike@… Owned by: mike@…
Priority: high Milestone: 1.next
Component: support Version: 1.7
Keywords: Cc:
Blocked by: Blocking:

Description

Just including the jquery js file in the default PhoneGap BlackBerry project (index.html) crashes the simulator when you launch the app. I can confirm that this does not happen with 1.6.4

It doesn't seem to crash my device (os 6) but not being able to debug in the simulator will make life very difficult (and not worth upgrading)

I am using the bbery simulator: 9930 (os 7).

I wish i had more debugging information but it is difficult to get any info when debugging a phonegap app.

Change History (24)

comment:1 Changed 7 years ago by dmethvin

Owner: set to mike@…
Status: newpending

Does it happen on both the compressed and uncompressed versions? Can you try the older 1.7 pre-release versions so we can narrow down where the problem lies?

http://code.jquery.com/jquery-1.7b1.js

http://code.jquery.com/jquery-1.7b2.js

comment:2 Changed 7 years ago by anonymous

I was testing a compressed 1.7rc1 version

-jquery-1.7b1.js (uncompressed) crashes

-jquery-1.7b2.js (uncompressed) crashes

-jquery-1.6.4.min.js (compressed) works

comment:3 Changed 7 years ago by anonymous

I will try to comment out code to see where it crashes

comment:4 Changed 7 years ago by mike@…

Status: pendingnew

I have no clue why it is crashing but if you comment out line 1635:

supports.supportsFixedPosition = (inner.offsetTop === 20
inner.offsetTop === 15);

we no longer crash. Does this make any sense?

comment:5 Changed 7 years ago by dmethvin

Component: unfiledsupport
Milestone: None1.7
Owner: changed from mike@… to dmethvin
Priority: undecidedblocker
Status: newassigned

Wow, thanks for digging into this! I suspect it's a duplicate of #10613 which crashes IE8 about five lines above that. Can you try a test where you include jQuery at the bottom of the page, just before the end of the body? If that works then I think we are dealing with the same problem.

comment:6 Changed 7 years ago by mike@…

no prob, I was already set up for it and what a great way to spend a Friday night ;)

but it still crashes if I put it before the end </body>

comment:7 Changed 7 years ago by dmethvin

Milestone: 1.71.7.1
Priority: blockerhigh
Version: 1.7rc11.7

Mike, does the 1.7 final still crash the simulator? We haven't given up and will be doing some other changes to 1.7.1 in the support.js area but this didn't seem critical enough to prevent the release.

comment:8 Changed 7 years ago by mike@…

Still happens in 1.7, I (and anyone else building PhoneGap apps for BlackBerry) will have to stick with 1.6.4 until this is fixes because there is no workaround that I am aware of.

Not a big deal for me because I do not need any of the new features in 1.7 but I would like to eventually upgrade.

comment:9 Changed 7 years ago by timmywil

The difference is that the fixed position tests aren't run at all on pageload in 1.6.4. @mike: perhaps if you try to run http://api.jquery.com/offset in 1.6.4, you'll get the same error when it tries to determine fixed position support? I would test, but lack a bb.

comment:10 Changed 7 years ago by mike@…

Calling:

$(window).offset();

in 1.6.4 does not crash the app

comment:11 Changed 7 years ago by Rick Waldron

Milestone: 1.7.11.next

comment:12 Changed 7 years ago by dmethvin

Owner: changed from dmethvin to mike@…
Status: assignedpending

Mike, does this still occur? We don't have a simple way to reproduce so that makes it hard for us to fix as well.

comment:13 Changed 7 years ago by u.v.poblotzki@…

Yes, it still happens; BlackBerry simulator still crashes with 1.7.1 but not with 1.6.4.

comment:14 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:15 in reply to:  2 Changed 7 years ago by dblanco.software@…

Replying to anonymous:

I was testing a compressed 1.7rc1 version

-jquery-1.7b1.js (uncompressed) crashes

-jquery-1.7b2.js (uncompressed) crashes

-jquery-1.6.4.min.js (compressed) works

I have the same problem. By using jquery.1.6.4.min.js still happening. What is the solution to test in the simulator under these conditions?

comment:16 Changed 7 years ago by dmethvin

Resolution: invalid
Status: closedreopened

comment:17 Changed 7 years ago by dmethvin

Status: reopenedopen

Does the 1.8b2 release work?

What platform are you running the simulator on?

comment:18 in reply to:  17 Changed 7 years ago by anonymous

Replying to dmethvin:

Does the 1.8b2 release work?

What platform are you running the simulator on?

Sorry, the version 1.6.4 if it works, but stops working in conjunction with mobile jquery 1.1.0 in the SDK simulator WebWorks.

comment:19 Changed 7 years ago by dmethvin

Status: openpending

I know it's been a while, but I'm just checking to see if later versions work here. Or perhaps RIM updated their software? Nobody else has reported this and we don't have a way to diagnose it, so I'm inclined to close.

comment:20 Changed 7 years ago by kvinoth

We also ran into the same problem. Just including the JQuery js (compressed or uncompressed of ver 1.7.2) was causing the BB Simulator (os 7) to crash.

Do we have any solution to this yet? Is this solved in 1.8?

This is really preventing us from having a hybrid app using JQuery on BlackBerry. Please help.

comment:21 Changed 7 years ago by kvinoth

Commenting line below (line 1636) as recommended above solves the problem

offsetSupport.fixedPosition = ( inner.offsetTop === 20 || inner.offsetTop === 15 );
Last edited 7 years ago by dmethvin (previous) (diff)

comment:22 Changed 7 years ago by dmethvin

Status: pendingopen

Okay, not sure if we can fix this but at least we have a repro and a suspect.

comment:23 Changed 6 years ago by dmethvin

Status: openpending

Is this still a problem? Can someone who was affected test with jquery-1.9b1.js and see if it's still an issue?

comment:24 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.