Bug Tracker

Opened 8 years ago

Closed 8 years ago

#10600 closed bug (invalid)

Valid selector throws exception in IE7/8

Reported by: gxclarke@… Owned by: gxclarke@…
Priority: low Milestone: None
Component: selector Version: 1.7b2
Keywords: Cc:
Blocked by: Blocking:

Description

Sizzle is unable parse a selector that combines a pseudo-class with a pseudo-selector in IE 7 and 8.

The pseudo-class works:

alert($(":last-child").length);

And the pseudo-selector works:

alert($(":after").length);

But combining them together throws an exception in IE 7 and 8:

alert($(":last-child:after").length);

The same selector works in other browsers.

Change History (2)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledselector
Owner: set to gxclarke@…
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket to the jQuery bug tracker! Could you possibly provide us with a test case on jsFiddle reproducing the issue you were experiencing so that we can evaluate and confirm it on our end? (also please test with the RC)

comment:2 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.