Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 8 years ago

#1060 closed enhancement (wontfix)

slideIn and slideOut

Reported by: daemach Owned by:
Priority: trivial Milestone: 1.1.3
Component: effects Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description

This is probably a milestone 2.0 thing, but would it make sense to deprecate slideUp and slideDown in favor of slideIn and slideOut? The latter would match fadeIn and fadeOut which would make the effects group more consistent. The two could be given direction parameters such as: slideIn("left|right|up|down","speed",callback function).

I've debated even bringing this up because it's such a major change, but there are some benefits. It wouldn't be hard to update my existing code by doing a global replace slideUp( with slideOut("up", and then slideOut("up",) with slideOut("up")...

FWIW...

Change History (1)

comment:1 Changed 13 years ago by john

need: Review
Resolution: wontfix
Status: newclosed

I'm going to have to disagree on the naming scheme. While the naming may not be perfectly ideal, it does give the user a good idea of the expected functionality. Additionally, making API changes for the sake of making API changes isn't really on the radar right now. I'm going to mark this as "wontfix", but we can re-open it for consideration if we ever get to the point where we want to make big, sweeping, API changes.

Note: See TracTickets for help on using tickets.