Bug Tracker

Opened 8 years ago

Closed 8 years ago

#10597 closed bug (invalid)

IE8, $(document).height() != $(window).height()

Reported by: roel@… Owned by:
Priority: low Milestone: None
Component: dimensions Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

The example of jquery (http://api.jquery.com/height/) of the .height()-function gives back strange results.

The document is not larger then the viewport so $(document).height() (125px) shouldn't return a larger value then $(window).height() (121px).

IE9 doesn't have that problem and I haven't tested IE6 and IE7 because I'm lucky enough to not need to give support to those browsers anymore. :-)

Too reproduce I think it easier for you guys that you put the example in the latest version of jQuery to test it.

Change History (1)

comment:1 Changed 8 years ago by timmywil

Component: unfileddimensions
Priority: undecidedlow
Resolution: invalid
Status: newclosed

It is just a matter of different default styles across browsers from within the iframe.

Note: See TracTickets for help on using tickets.