Skip to main content

Bug Tracker

Side navigation

#10585 closed bug (worksforme)

Opened October 26, 2011 05:59PM UTC

Closed October 26, 2011 06:38PM UTC

Last modified October 26, 2011 07:12PM UTC

loading in a form via .load() the input and select elements don't work in ipad

Reported by: Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

I'm loading in html pages with form elements into a page via the .load method (without a suffixed selector expression).

These work in all desktop browsers but the form elements top working - nothing happens when you touch them - on the iPad.

if I load the page directly in the iPad, the form elements work.

What is happening with .load and how do I get around this (I've attempted to inlcude jquerymobile and it still doesn't work if the page is brought in via the .load() method)

Attachments (0)
Change History (2)

Changed October 26, 2011 06:38PM UTC by ajpiano comment:1

resolution: → worksforme
status: newclosed

Thanks for taking the time to contribute to the jQuery project, but I could not confirm this bug.

I created a fiddle with a dead-simple form, and an empty form, then used $.fn.load to copy in the contents of the first form into the second, then tried it on an iPad on iOS5.

The input and select elements that were loaded dynamically work just fine on my iPad.

If you have a fiddle that proves otherwise, please provide it - for now I'm closing as worksforme.

Changed October 26, 2011 07:12PM UTC by anonymous comment:2

hmm. well your jsfiddle certainly works (on IOS4.3 ipad simulator). I must have some code that's conflicting or maybe a markup error. Thank you!