Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10555 closed bug (duplicate)

.live() + .trigger("change") throws a run time error

Reported by: prashantjain68 Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

I have an element which is not added to the DOM. An event handler has been attached via .live(). The element dispatches a change event via trigger() and I get the following error ...

<DocumentFragment> has no method getAttribute.

Sample source code ... <html>

<head>

<script type="text/javascript" src="jquery.js"></script> <script>

$(document).ready(function() {

jQuery("[groupId='hobbies']").live("change", myHandler); var $checkbox = $("<input type='checkbox' groupId='hobbies'/>"); $checkbox.trigger("change");

});

function myHandler() { }

</script>

</head>

<body> </body>

</html>

NOTE: I do not get an error If this checkbox was appended to the DOM.

Change History (3)

comment:1 Changed 8 years ago by prashantjain68

Seems like this got submitted twice. This is a duplicate of 10556.

comment:2 Changed 8 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:3 Changed 8 years ago by dmethvin

Duplicate of #10556.

Note: See TracTickets for help on using tickets.