Bug Tracker

Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#10521 closed bug (duplicate)

Omitting % sign after 0 in .animate property breaks animation in Chrome

Reported by: [email protected] Owned by:
Priority: low Milestone: None
Component: effects Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

Here's a jsfiddle demonstration of the problem. You can see in the .bad version that when the second menu slides in, it overlaps with the first menu in Chrome. This doesn't happen in FF.

The .good version works identically in both FF and Chrome. The only difference to .bad is the % sign after 0 in the .animate property.

http://jsfiddle.net/sRpYA/

Change History (3)

comment:1 Changed 11 years ago by timmywil

Component: unfiledeffects
Priority: undecidedlow
Status: newopen

This is difficult. We calculate the unit based on the user's input, not at all based on the current value of the style. We could perhaps fall back to that if no unit was provided and then fall back to 'px'.

comment:2 Changed 10 years ago by mikesherov

Resolution: duplicate
Status: openclosed

comment:3 Changed 10 years ago by mikesherov

Duplicate of #9505.

Note: See TracTickets for help on using tickets.