Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10508 closed bug (duplicate)

Complete incompatibility with ie8

Reported by: kurtsassenrath@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

IE8 is not compatible with jQuery 1.6.4, it gives the following error:

This command is not supported, line 1019

finally {

fired = [ context, args ]; firing = 0;

}

Change History (6)

comment:1 Changed 8 years ago by timmywil

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by timmywil

Duplicate of #9033.

comment:3 Changed 8 years ago by sergei.haller@…

Please reopen this bug. #9033 was fixed by removing the whole try-finally from the callback (see comment 26 there)

At line 1019, IE8 in compatibility mode still (1.6.4) throws an error. a "catch (pseudoError) {}" helps

comment:4 Changed 8 years ago by timmywil

Please check the latest version of jQuery. http://code.jquery.com/jquery-git.js I don't see a try/catch anywhere near that line.

comment:5 Changed 8 years ago by sergei.haller@…

1.6.4 is the latest non-1.7.x

about the jquery-git.js you are absolutely right: there is only one "finaly" in total. and the one has a "catch (pseudoError) {}"

Do you think it would be possible to fix 1.6.4 for the upcoming 1.6.5?

Thanks a lot!

comment:6 Changed 8 years ago by timmywil

There will not a 1.6.5. I recommend upgrading to 1.7.

Note: See TracTickets for help on using tickets.