Bug Tracker

Opened 4 years ago

Closed 4 years ago

#10504 closed bug (invalid)

live mouseenter/mouseleave - append dynamic childs cause bubbling

Reported by: marcinrosinski Owned by: marcinrosinski
Priority: low Milestone: None
Component: event Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:


to reproduce:

   $(this).append('<a id="rmp" href="#"><img style="border:0;" src="/images/remove.gif" /></a>');

so hovering #rmp will trigger mouseleave despite being child of #list


Change History (2)

comment:1 Changed 4 years ago by addyosmani

  • Component changed from unfiled to event
  • Owner set to marcinrosinski
  • Priority changed from undecided to low
  • Status changed from new to pending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 4 years ago by trac-o-bot

  • Resolution set to invalid
  • Status changed from pending to closed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.