Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10490 closed bug (invalid)

jQuery ajax 1.6.4 sporadic bug, browser independant

Reported by: softlion@… Owned by: softlion@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi, since I updated from 1.6 to 1.6.4 i have a new bug in a real production. I'm polling a json service which url is "/tick" every seconds using $.ajax (POST mode). I'm logging all 404, and per day I saw some browsers starts calling tickXHRB0978575529B486ABCA7EB68E0E44469XHR (instead of tick).

Is this a known issue ?

Here is the simple code:

var tickActionUrl = '/tick';

$(function() {
setInterval(onTick, 1000);
}


function onTick() {
        //After resuming from sleep, some browsers loose ajax settings ...
	if ($.ajaxSettings.type !== 'POST')
	    return something();
    
	$.ajax({
		url: tickActionUrl,
		isTick: true,
		success: onTickResponse,
		error: function() { something(); },
		dataType: 'json',
		timeout: 10000
	});
};

Change History (6)

comment:1 Changed 8 years ago by softlion@…

I forgot to mention i have a global setup:

$.ajaxSetup({
	type: 'POST',
	timeout: 30000,
	cache: false,
	// Firefox fix: Add correct header to ajax requests
        headers: { "X-Requested-With": "XMLHttpRequest" },
	data: "",
    traditional: true
});

comment:2 Changed 8 years ago by dmethvin

Owner: set to softlion@…
Status: newpending

We'd really need to see a test case, preferably something on jsFiddle, that demonstrated the problem.

If requests from some clients come to your server and have an unusual URL, it could be almost anything. For example maybe there is a poorly written Firefox extension or IE plugin that is messing up the request URL.

If you can narrow down the cause and determine that it is created by jQuery, please reply with the test case and we can investigate.

comment:3 Changed 8 years ago by softlion@…

Status: pendingnew

User agents having the "bug" yesterday: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.0; Trident/5.0) Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

And the day before: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

Ok there is only 3 clients in 2 days, not that much ... I updated the script to detect the bug as a workaround.

Can it be a browser js'vm bug when there is no more free memory ?

comment:4 Changed 8 years ago by diopralinato

I think that dmethvin means:

Use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

Then copy/paste here a link to your test case.

comment:5 Changed 8 years ago by timmywil

Status: newpending

comment:6 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.