Skip to main content

Bug Tracker

Side navigation

#10475 closed bug (wontfix)

Opened October 11, 2011 03:49PM UTC

Closed October 11, 2011 04:10PM UTC

Redundant naming of $.support.supportsFixedPosition

Reported by: Owned by:
Priority: low Milestone: None
Component: support Version: 1.7b1
Keywords: Cc:
Blocked by: Blocking:

The naming of the property is weird, as the "support" part is already in the name of the support object, and most of the other properties in there could be prefixed with "supports" too. Shouldn't it simply be called $.support.fixedPosition?

Attachments (0)
Change History (1)

Changed October 11, 2011 04:10PM UTC by rwaldron comment:1

component: unfiledsupport
priority: undecidedlow
resolution: → wontfix
status: newclosed

supportsFixedPosition was originally a property of jQuery.offset and was recently moved to but must enforce the original naming to remain backwards compat.