Skip to main content

Bug Tracker

Side navigation

#1044 closed bug (fixed)

Opened March 13, 2007 01:13PM UTC

Closed April 30, 2007 01:45AM UTC

Last modified October 14, 2008 10:46AM UTC

Error appending colgroup

Reported by: zildji4n Owned by:
Priority: critical Milestone: 1.1.3
Component: core Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

I get the javascript error message "[ object error ]" while trying to change the content of an element, such as <div> or <form>. I have tried both html() and appendTo and keep getting the same error message.

Attachments (0)
Change History (4)

Changed March 14, 2007 05:32PM UTC by daemach comment:1

The same problem exists in FF2 when using append or appendTo. Attempting to append a select element, with options or without, or <colgroup></colgroup> fails. The element gets created but it's not appended to the target element.

In the case of a select with an attached option the option gets appended to the target element, but the select does not.

More info here:

Changed April 04, 2007 06:50PM UTC by john comment:2

component: buildcore
need: → Test Case
summary: Problem in IE, trying to update content using html() or appendTo()Error appending colgroup

Ok, I know what this problem relates too - I'll look into it.

Also, make sure that your bugs go in the right categories (like core, event, fx, etc.) otherwise, we may not see it as a known bug.

Changed April 29, 2007 02:56AM UTC by brandon comment:3

Replying to [comment:1 daemach]:

Appending a select element is fixed in the latest SVN.

Changed April 30, 2007 01:45AM UTC by brandon comment:4

resolution: → fixed
status: newclosed

Fixed in Rev. [1820]