Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#10425 closed bug (duplicate)

animate's complete infinite loop on exception

Reported by: rg1693@… Owned by:
Priority: low Milestone: None
Component: effects Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

When the 'complete' callback provided to animate() throws an exception, jquery will execute it again and again. this is done like this:

$('#bbb').animate(
    {width:200},
    1000,
    undefined,
    function() { throw "lets start again"}
);

here's a demonstration: http://jsfiddle.net/b5Ydg/1/

Change History (2)

comment:1 Changed 6 years ago by timmywil

Component: unfiledeffects
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 6 years ago by timmywil

Duplicate of #5684.

Note: See TracTickets for help on using tickets.