Bug Tracker

Opened 7 years ago

Closed 7 years ago

#10407 closed bug (invalid)

memory leak

Reported by: lexerq@… Owned by: lexerq@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

I create an element with the context menu. When I create html element tr: var newTr = jQuery('<tr oncontextmenu="return openMyMenu();"></tr>'); I have a memory leak.

But, when I create html element tr with this method: var newTr = document.createElement('tr'); newTr.oncontextmenu = openMyMenu; I don't have a memory leak.

What this is?

It is my error? Or it is bug in jQuery?

Change History (6)

comment:1 Changed 7 years ago by Rick Waldron

Owner: set to lexerq@…
Status: newpending

Can you provide some evidence of this "memory leak"?

comment:2 Changed 7 years ago by lexerq@…

Status: pendingnew

Data is updated every 15 seconds. Every 7 minutes browser consumes 50 MB of RAM. I understand that this is a bad argument, but it's all there is.

comment:3 Changed 7 years ago by addyosmani

We'll need some additional evidence to avoid this ticket from being closed. At minimum, could you supply us with a complete test case on jsFiddle.net that we can evaluate ourselves to check if the behaviour can be reproduced?

comment:4 Changed 7 years ago by dmethvin

Status: newpending

We definitely need a test case before we can continue.

comment:5 Changed 7 years ago by anonymous

The code is very large. I will try to reproduce the memory leak using a similar code and post on jsfiddle.net

comment:6 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.