Bug Tracker

Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#10383 closed bug (duplicate)

Attribute selector inconsistant in IE8

Reported by: anonymous Owned by: timmywil
Priority: low Milestone:
Component: attributes Version: 1.7b1
Keywords: deprecate Cc:
Blocked by: Blocking:

Description

Attribute selector inconsistant in IE8

http://jsfiddle.net/5DTfu/24/

The attribute selector is not inconsistant in IE8

Change History (8)

comment:1 Changed 5 years ago by anonymous

result in IE8 is different from FF and Chrome.

comment:2 Changed 5 years ago by rwaldron

  • Component changed from unfiled to attributes
  • Priority changed from undecided to low
  • Resolution set to invalid
  • Status changed from new to closed

"value" is not a valid content attribute of textarea

http://www.w3.org/TR/html5/the-button-element.html#the-textarea-element

comment:3 Changed 5 years ago by timmywil

  • Resolution invalid deleted
  • Status changed from closed to reopened

Because we hooked up jQuery.attr to attribute retrieval in Sizzle and because we currently have the value attrHook in place to always retrieve the value property rather than the content attribute for back-compat reasons AND because Sizzle tries querySelectorAll first, IE6/7 selects with the value property and other browsers select with the attribute (because querySelectorAll follows spec and uses the attribute). This is an inconsistency for all inputs, but will not be fixed until we have deprecated and removed the value attrHook.

http://jsfiddle.net/timmywil/5DTfu/26/

I'll reopen so we can keep track of possible value attrHook deprecation. .prop or .val should be used to retrieve the value property anyway.

comment:4 Changed 5 years ago by timmywil

  • Keywords deprecate added
  • Milestone changed from None to 1.8
  • Owner set to timmywil
  • Status changed from reopened to assigned

comment:5 Changed 5 years ago by anonymous

cool, I am not realy using 'value' this way, just curious how the attribute selector is going to handle that since the modification of .attr() and .prop()

comment:6 Changed 5 years ago by timmywil

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:7 Changed 5 years ago by timmywil

Duplicate of #9830.

comment:8 Changed 5 years ago by dmethvin

  • Milestone 1.8 deleted

Please follow the bug reporting guidlines and use jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

Modify Ticket

Change Properties
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.