Bug Tracker

Opened 7 years ago

Closed 7 years ago

#10381 closed bug (invalid)

Inlcuding jQuery into Firefox extension growing up CPU load

Reported by: andrii.gakhov@… Owned by:
Priority: low Milestone: None
Component: misc Version: 1.6.4
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery 1.6.4, Firefox 7 (and Firefox 6), Ubuntu 11.04

When I am installing a Firefox extension which includes jQuery 1.6.4 (and does nothing) the CPU load of firefox growing up (from 1-3% to 7-9%). I noticed that the issue not occurred in jQuery 1.4

To illustrate the problem I've created a minimal example - 3 "empty" extensions for Firefox (http://www.gakhov.info/resources/bugs/jquery_bug_extensions.zip) with/without jQuery

  1. extension without any jQuery (firefox CPU 1-3%) - OK
  2. extension with jQuery 1.4 (firefox CPU 1-3%) - OK
  3. extension with jQuery 1.6.4 (firefox CPU 7-9%) - PROBLEM


To reproduce the issue (using my minimal examples):

  1. Install extension_with_nothing.xpi extension (http://www.gakhov.info/resources/bugs/extension_with_nothing.xpi)
  2. Restart Firefox
  3. Check top utility for CPU load (starts with 50% and stabilized on 1-3% CPU)
  4. Remove extension_with_nothing.xpi extension
  5. Restart Firefox

  1. Install extension_with_jquery_1.4.xpi extension (http://www.gakhov.info/resources/bugs/extension_with_jquery_1.4.xpi)
  2. Restart Firefox
  3. Check top utility for CPU load (starts with 50% and stabilized on 1-3% CPU)
  4. Remove extension_with_jquery_1.4.xpi extension
  5. Restart Firefox

  1. Install extension_with_jquery_1.6.4.xpi extension (http://www.gakhov.info/resources/bugs/extension_with_jquery_1.6.4.xpi)
  2. Restart Firefox
  3. Check top utility for CPU load (starts with 50% and stabilized on 7-9% CPU)
  4. Remove extension_with_jquery_1.6.4.xpi extension
  5. Restart Firefox

Why CPU load is increasing just because I include the jQuery 1.6.4?

Change History (1)

comment:1 Changed 7 years ago by timmywil

Component: unfiledmisc
Priority: undecidedlow
Resolution: invalid
Status: newclosed

I don't think we'll be able to devote resources to investigating CPU load in firefox extensions, but jQuery does not take any CPU once it has been loaded, so if there is a problem, it is likely in firefox.

Note: See TracTickets for help on using tickets.