Bug Tracker

Opened 10 years ago

Closed 10 years ago

#10375 closed bug (fixed)

Do not include `type` in jQuery.event.props

Reported by: [email protected] Owned by: dmethvin
Priority: blocker Milestone: 1.7
Component: event Version: 1.7b1
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Rick Waldron)

The inclusion of type in the jQuery.event.props list will clobber the type that is set in jQuery.Event when it is passed through jQuery.event.fix()

Original ticket:

jQueryUI slider works well with latest 1.6 Sliding with mouse malfunctions. Get "RangeError: Maximum call stack size exceeded. Line 4155" On Safari,Chrome,Firefox

http://jsfiddle.net/3evgS/ (No 1.7b1 yet, but this should malfunction with it)

Change History (5)

comment:1 Changed 10 years ago by Rick Waldron

Component: unfiledselector
Milestone: None1.7
Priority: undecidedblocker
Status: newopen

Confirmed. This seems to be rooted in Sizzle.

Version 0, edited 10 years ago by Rick Waldron (next)

comment:2 Changed 10 years ago by Rick Waldron

Component: selectorevent

comment:3 Changed 10 years ago by gnarf

Seems that removing "type" from $.event.props will fix this: http://jsfiddle.net/3evgS/3/

comment:4 Changed 10 years ago by Rick Waldron

Description: modified (diff)
Owner: set to dmethvin
Status: openassigned
Summary: Stacksize exceeded on slider mouseeventDo not include `type` in jQuery.event.props

comment:5 Changed 10 years ago by Dave Methvin

Resolution: fixed
Status: assignedclosed

Fix #10375. Don't put type in jQuery.event.props

It's already set in jQuery.Event, and copying it can clobber values set by the caller, e.g., the UI widget factory.

Changeset: 96a44a86d870f2634c82a4148d22d0a07044ba77

Note: See TracTickets for help on using tickets.