Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10348 closed bug (duplicate)

Ajax "deferred" error ?

Reported by: froddy Owned by:
Priority: high Milestone: None
Component: deferred Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

I was testing ajax calls to my json web service (.net), and encountered the following error, when intentionally specifying an incorrect name for my web method. This error also occurs when attempting to call (via ajax) a web method, and the web server (IIS) has been intentionally stopped (i.e. is turned OFF) – for testing purposes.

The problem is that an error is NOT returned to my (deferred) error handler, but rather I get the following JavaScript error:

"Microsoft JScript runtime error: Exception thrown and not caught"

… and a break point at line 1011, of the jquery file “jquery-1.6.2.js”, viz.:

finally {

fired = [ context, args ]; firing = 0;

}

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfileddeferred
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by timmywil

Duplicate of #9033.

Note: See TracTickets for help on using tickets.