Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10274 closed bug (duplicate)

checked broken for radio buttons

Reported by: sam.garnham@… Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.6.4rc1
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/uvpAc/1/

Reproduced with both 1.6.3 and 1.6.4 - fine in 1.6.2.

Two radio buttons with second checked. onclick of first, attr("checked") still returns "checked" for the second.

Change History (5)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledattributes
Priority: undecidedlow
Resolution: worksforme
Status: newclosed

Thanks for submitting a ticket. I've reviewed your test case and I believe you're incorrectly using .attr() rather than .prop() to check for the checked value. If you take a look here, a corrected version of your test case works fine with both jQuery 1.6.2,.3 and edge (.4). http://jsfiddle.net/addyosmani/uvpAc/3/

See here for just one of the explanations behind .attr() vs .prop() (noting that this change was introduced in jQuery 1.6): http://forum.jquery.com/topic/please-explain-attr-vs-prop-change-in-1-6

comment:2 Changed 8 years ago by timmywil

Resolution: worksforme
Status: closedreopened

This is legit. We have the boolHook in place so that attr will work as it did before for booleans. We encourage people to use prop for boolean attributes, but attr should work as well until it is officially deprecated. I'm marking this ticket as a dupe of a later one.

comment:3 Changed 8 years ago by timmywil

Resolution: duplicate
Status: reopenedclosed

comment:4 Changed 8 years ago by timmywil

Duplicate of #10278.

comment:5 Changed 8 years ago by addyosmani

Thanks for the clarification on this one timmywil!

Note: See TracTickets for help on using tickets.