Bug Tracker

Opened 7 years ago

Closed 7 years ago

#10252 closed bug (worksforme)

.val()

Reported by: TheBuzzer@… Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

Not a bug, but it seems to have to way to use .val()!

Variable as a link var sVar = $('#Item').val(); Will set a link to Item value $('#Item').val('Text'); sVar will take the value 'Text'

Independant Variable should be set like this var sVar; sVar = $('#Item').val(); $('#Item').val('Text'); Now sVar will keep the old value

Tested on Firefox

Change History (1)

comment:1 Changed 7 years ago by timmywil

Component: unfiledattributes
Priority: undecidedlow
Resolution: worksforme
Status: newclosed

I'm not able to reproduce this. http://jsfiddle.net/timmywil/kfckE/ I don't think it's possible that it could be pass by reference.

Note: See TracTickets for help on using tickets.