Bug Tracker

Opened 10 years ago

Closed 10 years ago

#10247 closed bug (invalid)

Pressing the CTRL and any other key prevents .keydown() and .keyup() from capturing events.

Reported by: [email protected] Owned by: [email protected]
Priority: low Milestone: None
Component: event Version: 1.6.3
Keywords: Cc:
Blocked by: Blocking:

Description

I've been working on a library for my game engine Red Locomotive to allow game developers to bind to the hole keyboard. I've been successful, but have noticed a problem with jQuery.

If i press and hold the CTRL key, then any other key, the keydown function stops capturing keydown events. Then when I release the CTRL key the keyup event for the CTRL key never fires.

Change History (4)

comment:1 Changed 10 years ago by timmywil

Component: unfiledevent
Owner: set to [email protected]
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by anonymous

Here is a jsFiddle that can be used to reproduce the bug: http://jsfiddle.net/M93tR/1/

comment:3 Changed 10 years ago by dmethvin

I do see that behavior with key combos that correspond to some browser hotkeys, for example ctrl-n, but not with ctrl-a for example. If the behavior you see is consistent with this description, then it's not something jQuery would be able to fix since the browser is not delivering key data we can detect: http://unixpapa.com/js/key.html

If you write this in pure DOM does the problem persist?

comment:4 Changed 10 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.