Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10235 closed bug (duplicate)

Timers deletion race condition causes animations to stop

Reported by: Aitor Guevara <aitorciki@…> Owned by: gnarf
Priority: low Milestone: None
Component: effects Version: 1.6.3
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery.fx.tick doesn't check if the timers array has been modified inside the timer step function. If a stop() has been registered in an animation callback, the timer will be deleted inside the step function, and tick will delete the wrong timer since the loop counter now points to the next one.

The problem is demonstrated at http://jsfiddle.net/aitorciki/LE9eT/ .

Pull request #495 fixes the problem and adds a test.

Change History (5)

comment:1 Changed 8 years ago by Rick Waldron

Owner: set to gnarf
Status: newassigned

comment:2 Changed 8 years ago by Rick Waldron

Component: unfiledeffects
Priority: undecidedlow

comment:3 Changed 8 years ago by gnarf

This might possibly be a dupe of #6641

comment:4 Changed 8 years ago by gnarf

Resolution: duplicate
Status: assignedclosed

Confirmed - This behavior is already fixed in master http://jsfiddle.net/LE9eT/4/

comment:5 Changed 8 years ago by gnarf

Duplicate of #6641.

Note: See TracTickets for help on using tickets.