Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#10224 closed bug (duplicate)

wrong value for selector property on chained finds with comma in selector

Reported by: anonymous Owned by: anonymous
Priority: undecided Milestone: None
Component: selector Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

If I do: var a = jQuery("table:first").find("tr").find('img,a')

I correctly get all the images and links in the rows of the first table.

However, the returned jQuery object has this as the value for its selector property:

console.log(a.selector); "table:first tr img,a"

which is just a concatenation and would not return the same thing at all:

jQuery("table:first tr img,a")

Change History (8)

comment:1 Changed 10 years ago by Rick Waldron

Component: unfiledselector
Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by anonymous

Status: pendingnew

comment:3 Changed 10 years ago by Rick Waldron

So, which part is not doing what is expected? http://gyazo.com/3048146e8db6b69e65a0fddd7e980c8e.png

comment:4 Changed 10 years ago by Rick Waldron

Status: newpending

comment:5 Changed 10 years ago by anonymous

Status: pendingnew

The second link should not be red, and the first link should read: "table img, table a" assuming the selector property has any meaning.

comment:6 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Don't look at the .selector property, it's not documented to survive traversal methods and is only to be used internally.

comment:7 Changed 10 years ago by dmethvin

Duplicate of #6754.

comment:8 Changed 10 years ago by anonymous

Thanks!

Note: See TracTickets for help on using tickets.