Bug Tracker

Opened 8 years ago

Closed 8 years ago

#10211 closed bug (worksforme)

removeAttr('id') will clear class in IE7

Reported by: anonymous Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

In IE7, calling removeAttr('id') will clear the "class" attribute of the element automatically.

Test case: http://jsfiddle.net/B293e/1/

only IE7 has this problem. IE6,8,9 will not clear the "class" attribute.

Change History (1)

comment:1 Changed 8 years ago by timmywil

Component: unfiledattributes
Priority: undecidedlow
Resolution: worksforme
Status: newclosed

I'm unable to reproduce. I think your html was invalid. http://jsfiddle.net/timmywil/B293e/2/

Note: See TracTickets for help on using tickets.