Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10192 closed bug (duplicate)

wrong event type with bind for mouse enter/over and mouse leave/out

Reported by: tigbro Owned by: tigbro
Priority: low Milestone: None
Component: event Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

There are already several tickets in this direction (e.g. #9211). With query 1.6.2 they were marked as duplicate of #9069. However, the bug still exists in query 1.6.2:

Reproduce:

$(document).bind("mouseenter", function(event){});

$(document).bind("mouseover", function(event) { console.log(event.type); });

Most of the time, the console logs "mouseenter" instead of "mouseout" when the mouse hovers over some elements. Note that the error does no more exist when the empty listener for "mouseenter" is deleted.

Same is true for mouseleave / mouseout.

Tested with Chrome 13.

Change History (4)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledevent
Owner: set to tigbro
Priority: undecidedlow
Status: newpending

Thanks for submitting a ticket. The test case in 9069 works fine with jQuery edge/git http://jsfiddle.net/NNLkN/10/, however if you would like for us to re-evaluate, please submit a complete test case reproducing the behaviour mentioned on jsFiddle.net so that we can test further.

comment:2 Changed 8 years ago by Rick Waldron

Resolution: duplicate
Status: pendingclosed

If you spent the time searching for existing tickets and found them closed as duplicate, why would you then file another duplicate? All you need to do is comment on the _original_ ticket to get attention to it.

comment:3 Changed 8 years ago by Rick Waldron

Duplicate of #9069.

comment:4 Changed 8 years ago by tigbro

Created a jsfiddle and added a comment to #9069.

Note: See TracTickets for help on using tickets.