Bug Tracker

Opened 8 years ago

Closed 7 years ago

#10182 closed bug (wontfix)

.show(duration) on td in chrome mispositions content

Reported by: ysth Owned by:
Priority: low Milestone: None
Component: effects Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

.show with a duration, even a duration of 0, when used on a td is positioning the content to the right where it should be in chrome (13.0.782.215) and chromium (15.0.854.0). .show() with no duration has no problem.

Test case: http://jsfiddle.net/WLVM3/

Change History (4)

comment:1 Changed 8 years ago by addyosmani

Component: unfiledeffects
Priority: undecidedlow
Status: newopen

Confirmed, however there are known issues with animating table elements: http://jsfiddle.net/addyosmani/ybPn7/. I'll defer to dmethvin in case he has any further comments to add here.

comment:2 Changed 8 years ago by ysth

I mostly was interested in trying to get the underlying chromium bug (assuming there is one) reported.

Though it seems questionable that jquery apparently does something different for no animation vs. 0-time "animation".

comment:3 Changed 8 years ago by anonymous

Interestingly, show() doesn't have this bug...

http://jsfiddle.net/g8Jdy/1/

comment:4 Changed 7 years ago by mikesherov

Resolution: wontfix
Status: openclosed

This is fixed as of Chrome 19, and is also fixed on jQuery edge because it's a duplicate of another bug. Closing as wontfix though, because it's fixed natively.

Note: See TracTickets for help on using tickets.