Bug Tracker

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1018 closed bug (duplicate)

IE error in complex selector

Reported by: aichinge Owned by:
Priority: major Milestone: 1.1.3
Component: core Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description

I have selector like this '.EnFormActive//#en_form_23 td' The html code is:

<div class="EnFormPassive">

<fieldset>

<fieldset>

<legend>legend</legend> ...

</fieldset>

<fieldset>

<legend>bbb</legend> <div class="formLine"></div> <table id="pusobnost_tab_en">

<thead>

<tr>

<th></th> <th></th> <th></th>

</tr>

</thead> <tbody>

<tr id="en_form_23">

<td></td> <td></td> <td><a id="editFOALinkEn_23" href="#">xxx</a></td>

</tr>

</tbody> </table>

</fieldset> </div>

I use jQuery to swith main div class between EnFormPassive and EnFormActive. So I want to know how many td's are selected. When is passive and I use the selector abowe, IE tells me about error "getElementById is null or is not object". FireFox works fine and return 0;

Change History (3)

comment:1 in reply to:  description Changed 13 years ago by aichinge

Replying to aichinge:

I have selector like this '.EnFormActive//#en_form_23 td' The html code is:

In IE works fine: $('.EnFormActive').find('#en_form_23') but not in FF :-)

comment:2 Changed 13 years ago by aichinge

In the last note there is a mistake, in FF it works fine too.

comment:3 Changed 13 years ago by john

Milestone: 1.1.3
need: Review
Resolution: duplicate
Status: newclosed

I'm fairly certain that this is a duplicate of #986; which was just resolved. Please correct me if I'm wrong.

Note: See TracTickets for help on using tickets.